Problems with Autostand 5.0.1

More
2 years 2 months ago #296 by gb
Problems with Autostand 5.0.1 was created by gb
I installed only the autostand component in a new joomla installation 3.9.1, I created a category and placed a car inside it. When I assign the display of autostand categories to a menu item, it does not work and reports the following error:

Warning: require_once(/web/htdocs/www.mgautosr.it/home/administrator/includes/toolbar.php): failed to open stream: No such file or directory in /web/htdocs/www.mgautosr.it/home/components/com_autostand/autostand.php on line 20
Fatal error: require_once(): Failed opening required '/web/htdocs/www.mgautosr.it/home/administrator/includes/toolbar.php' (include_path='.:/php7.2/lib/php') in /web/htdocs/www.mgautosr.it/home/components/com_autostand/autostand.php on line 20

doing a search I realized that the file that the component actually looks for is called subtoolbar.php and not toolbar.php .... this modifying the file autostand.php the menu item seems to work correctly, clicking on it comes out the category created in the component, but clicking on this category comes out another error:


Warning: A non-numeric value encountered in /web/htdocs/www.mgautosr.it/home/components/com_autostand/lib/functions.php on line 586

Warning: A non-numeric value encountered in /web/htdocs/www.mgautosr.it/home/components/com_autostand/lib/functions.php on line 586

Warning: A non-numeric value encountered in /web/htdocs/www.mgautosr.it/home/components/com_autostand/lib/functions.php on line 586

Warning: A non-numeric value encountered in /web/htdocs/www.mgautosr.it/home/components/com_autostand/lib/functions.php on line 586


Is it a bug to report or my mistake in something?

Please Log in or Create an account to join the conversation.

More
2 years 2 months ago #297 by Administrator
Replied by Administrator on topic Problems with Autostand 5.0.1
Coment or remove the line 20 in file components/com_autostand/autostand.php
//require_once(JPATH_ADMINISTRATOR.'/includes/toolbar.php');
Since this option is no longer available in Joomla, we've removed it in the next version of Autostand 6.0. To edit/manage autostand, you need to use the backend. Autostand uses Joomla ACL, so you create the acess to your vendors and they will only see their own cars.

We're updating Autostand, and new options/features will be updated, others removed. Our demo at www.autostand.net is now running Autostand 6 with Joomla 3.9.1

Please Log in or Create an account to join the conversation.

More
2 years 2 months ago #298 by gb
Replied by gb on topic Problems with Autostand 5.0.1
The second part of the problem is unresolved. Removed line 20 from autostand.php, clicking on the menu item check the category but when I click on the category gives the errors mentioned above concerning the line 586 of the function.php.
I would also like to understand when version 6.0 will be available and if for those like me who bought the platinum pack will have the free update.

Please Log in or Create an account to join the conversation.

More
2 years 2 months ago #301 by gb
Replied by gb on topic Problems with Autostand 5.0.1
I still wait for the solution to the problem...

Please Log in or Create an account to join the conversation.

More
2 years 2 months ago #302 by Administrator
Replied by Administrator on topic Problems with Autostand 5.0.1
Contact us using the contact form, so we can send the new autostand 6. Do not post your email in the forum, use the contact form
Regards

Please Log in or Create an account to join the conversation.

More
2 years 2 months ago #304 by gb
Replied by gb on topic Problems with Autostand 5.0.1
I have contacted you via email for several days but I have not yet received a copy of Autostand 6.0 .... you have also put it in the shop ... please send me the copy

Please Log in or Create an account to join the conversation.

Cart

The cart is empty

Cart

The cart is empty

Autostand Packs